p:xquery 014 (AB)

Tests p:xquery: Value for @version is not valid, so XC0009 is expected.

Test ab-xquery-014.xml is expected to fail with error code err:XC0009.

The pipeline


      <p:declare-step xmlns:p="http://www.w3.org/ns/xproc" version="3.0">
         <p:output port="result"/>
         
         <p:xquery version="Use any version you like.">
            <p:with-input port="source">
               <doc xmlns="">
                  <para>A para.</para>
               </doc>
            </p:with-input>
            <p:with-input port="query">
               <result xmlns="">//para</result>
            </p:with-input>
         </p:xquery>
         <p:wrap-sequence wrapper="result"/>
      </p:declare-step>
   
MorganaXProc passing XML Calabash failing

Revision history

13 Sep 2019, Achim Berndzen

Tests for p:xquery (Partly ported from 1.0)